Mastodon

News from the Planet

Rebuilding a 1995 GPS Time Server so I don't get Telstra'd

Jeff Geerling — September 04, 2026

In June I purchased this TrueTime XL-AK time server, so I could learn more of the history of GPS-based time. I received it on June 22, and just 16 days later a similar GPS time server took down Australia's cell service for 12 hours! I made a short video about it but put off digging into the…

read more ➔

crumbles.blog: WTF is going on with R7RS Large? 2026 edition

Scheme Planet — September 04, 2026

Do come in and sit down. Pour yourself a cup of tea – I’ve just made a fresh pot. It’s been quite a ride since we last met to talk about these things. I became Scheme chair, but I’m not any more. Indeed, I’ve had to quit Scheme entirely. Let me tell you how this happened. Obviously, I’m a lot more…

read more ➔

Security scanning at Foundation scale

Apache News — September 03, 2026

By ASF Tooling and ASF Security During a three-day window in August 2026, the Apache Software Foundation (ASF) ran full security scans across 230 of the foundation’s repositories. The work was done by the ASF Security and ASF Tooling teams, within the Foundation’s Responsible AI Initiative (RAI),…

read more ➔

A reasonably practical guide to validating RFC 9421 HTTP Signatures for ActivityPub in PHP

Terence Eden — September 03, 2026

If you're reading this, you've probably been hitting your head against a brick wall trying to parse and decipher the new HTTP Signatures sent by Mastodon and other Fediverse servers. This is a basic and somewhat incomplete guide to accepting these signatures. I'm sure there are various gotchas, but…

read more ➔

Scheme Requests for Implementation: SRFI 281: Bytevector Utilities

Scheme Planet — September 02, 2026

SRFI 281 is now in draft status. This SRFI implements a modified version of the R6RS’s (rnrs bytevectors (6)) library, which has procedures for the serialization and deserialization of numbers into bytevectors, and conversion to/from Unicode. It also includes some procedures from SRFI 207 …

read more ➔

ASF Plus One Newsletter: August 2026

Apache News — September 02, 2026

**To receive Plus One directly to your inbox, sign up via the subscribe box below.**  Community News The ASF has announced the keynote speakers for Community Over Code Glasgow, taking place October 11–14, 2026 in Glasgow, Scotland. The lineup features Adjunct Faculty at Carnegie Mellon University…

read more ➔

Thinking about software freedom

Lars Wirzenius — September 01, 2026

Of what use is software freedom to someone who doesn't know how to program a computer? If I have the right to change the software that controls my devices, but lack the skill, knowledge, time, or money to do so, do I really have software freedom? This dilemma has worried me for a long time. I think…

read more ➔

The Apache® Software Foundation Announces Keynote Speakers for Community Over Code Glasgow 2026

Apache News — September 01, 2026

Open source leaders in software engineering education, sustainability, and the games industry to headline ASF’s flagship conference, October 11–14 in Glasgow, Scotland Wilmington, DE – September 1, 2026 – The Apache Software Foundation (ASF), the global home of open source software the world relies…

read more ➔

The Apache® Software Foundation Advances Open Source Infrastructure and Celebrates Community Growth in FY26

Apache News — September 01, 2026

Annual report highlights investments in people, infrastructure and standards to meet the growing demands on open source software  Wilmington, DE  – September 1, 2026 – The Apache Software Foundation (The ASF), the global home of open source software the world relies on, today released its annual…

read more ➔

Book Review: ActivityPub by Evan Prodromou ★★★★⯪

Terence Eden — September 01, 2026

As part of my grant from NLnet to improve my Fediverse bot project, I'm spending time making sure I understand all the fundamentals of ActivityPub. The problem with Internet standards is they're scattered all over the place. Abandoned forums, half-maintained wikis, mailing lists with obscure rules,…

read more ➔

Scheme Requests for Implementation: SRFI 262: Extensible pattern matcher

Scheme Planet — August 31, 2026

SRFI 262 is now in withdrawn status.A pattern matching form which can operate on arbitrary Scheme values is defined. It conforms to the following design principles. The syntax of patterns is declarative. The syntax is extensible in the same way that Scheme’s procedural syntax is extensible…

read more ➔

Review: Ruined Theatre's A Midsummer Night's Dream ★★★★☆

Terence Eden — August 31, 2026

The whole point about Shakespeare is that you can set the play on an intergalactic space station or an American high school and keep virtually the rest unchanged. What happens when you transpose Dream from a proscenium arch to a living wood? As the sun sets over the trees, what sprites will come out…

read more ➔

Before NTP there were Time and Daytime

Jeff Geerling — August 30, 2026

In building an NTP time demo on old Macs for VCF Midwest, I came across RFC 867 and RFC 868, for the 'Daytime' and 'Time' Protocols, respectively. My first exposure to any form of network time was when I upgraded from a used PowerBook 180c to my first 'new' computer, a Power Mac G3, in 2000. With…

read more ➔

Scheme Requests for Implementation: SRFI 280: Monads

Scheme Planet — August 30, 2026

SRFI 280 is now in draft status. Monads are a fundamental concept in functional programming. Schemers have been using them for a long time, albeit with ad hoc constructions only meant for specific monads. This SRFI deals with monads generally by extending Scheme with first-class monad…

read more ➔

ActivityBot is the recipient of an NLnet grant!

Terence Eden — August 30, 2026

Back in February, I applied for NLnet's Next Generation Zero grant. They were looking for Fediverse projects to help rewild the social media landscape. Or, as they describe it: Reclaim the public nature of the internet Small and medium-sized R&D grants between 5.000 and 50.000 euro, with the…

read more ➔

jointhefreeworld: Quest for the eternal Dock - lambdock

Scheme Planet — August 29, 2026

lambdock: quest for the eternal dock  # This is the story of lambdock: https://codeberg.org/jjba23/lambdock lambdock is a modern, hyper-hackable, Wayland-native desktop dock application (C and Guile Scheme + GTK4) w/ REPL. As a heavy computer user, spending most of my day enjoying…

read more ➔

Building a mini Homelab that fits in my carry-on

Jeff Geerling — August 28, 2026

I'm traveling to Chicago for VCF Midwest next month. I'll be demoing NTP time history on vintage Macs, with my own GPS-derived NTP service hosted on an Xserve G5, synced via NTP or a strange AppleTalk timing extension from the 1990s. So I built a little 'portable homelab' (pictured above) that…

read more ➔

The Apache® Software Foundation Announces New Top-Level Projects

Apache News — August 27, 2026

Introducing Apache Iggy™, a persistent message streaming platform written in Rust, and Apache Sourcelume, open source instrumentation for AI training-data provenance Wilmington, DE –  August 27, 2026 – The Apache Software Foundation (ASF), the global home of open source software the world…

read more ➔

Debugging Ubiquiti's 5G Backup on AT&T

Jeff Geerling — August 25, 2026

For a mobile 'mini homelab' project I'm working on, I wanted to use 5G Internet as a primary 'on-to-go' connection, but still have the ability to plug in another Internet connection when I put the mobile rack I'm building in a fixed location. I'll have more on that project soon, but I figured…

read more ➔

Shepherd, not robot

Guix Planet — August 25, 2026

This project, its code and its substance, have been brought to you by a small but dedicated herd of passionate and possibly stubborn human beings often referred to as “hackers.” This is how it all started more than 20 years ago and it hasn’t changed! I mean, why hack an init system, with a…

read more ➔

Getting the Steam Deck LCD working on a Raspberry Pi

Jeff Geerling — August 20, 2026

The BOE TV070WXM-TV0 LCD used in the original Steam Deck can be had for around $30. It's a serviceable 7" touchscreen with 400 nits of brightness and a resolution of 1280x800 (for a sharp 216 ppi). The specs are a lot nicer than the Pi 7" Touch Display, which costs twice as much, with giant…

read more ➔

We've Been Awarded An NLnet Grant for GNU Taler Packaging!

Guix Planet — August 19, 2026

We are happy to announce that Guixotic has been awarded a grant by NLnet as part of the NGI TALER Fund! This grant will fund our work to bring the main components and extensions of GNU Taler, a privacy-friendly payment system, to GNU Guix.

read more ➔

This month in Radicle CI, August 2026

Lars Wirzenius — August 19, 2026

This is a monthly newsletter about the current state of Radicle CI, what has happened recently, and near future plans. Current status Radicle CI is in production use. There are several CI nodes, and Lars runs a public one for open source Rust projects at callisto.liw.fi. Radicle CI use metrics I…

read more ➔

Hands-on with Raspberry Pi's CM5 Programming Jig

Jeff Geerling — August 19, 2026

In the before-times, when Raspberry Pi CM5s were (relatively) affordable, I built a number of Pi clusters (example), and one of the most annoying parts of the build was flashing Raspberry Pi OS to all the Pis. One, two, or even three Pis isn't a big deal, but once you hit 4+, the process of…

read more ➔

Apache Geode 2.0, Part III: Lessons Learned and the Path Forward

Apache News — August 18, 2026

What Geode 2.0 taught us—and what comes next By Jinwoo HwangLead Developer, Project Lead, and Release Manager, Apache Geode 2.0https://JinwooHwang.com This post is divided into three parts. Part I explains why Apache Geode 2.0 matters. Part II walks through how it was modernized. Part III looks…

read more ➔